Observed Behavior
Starting with the v2020.4 release, running the UiPath Assistant or Studio as Administrator, they are not going to be able to communicate with the Robot Service, which can throw the following errors:
Studio
The Robot Status displays a "Robot Error" message, and when trying to run or debug a process, an "Access Denied" error is displayed.
UiPath Assistant
The connection status in the Assistant is incorrectly reported offline and the process list is not available.
Robot Tray
The behavior is similar with the one in the Assistant.
Cause
UiPath Assistant and Studio (clients) require communication with Robot Service. This is a separate Windows process, which is automatically started by the client if it is not already running, with the same elevation level as the client.
For example:
- If Assistant was started with a privilege level (which automatically started the Robot Service with the same privilege level) and then Studio is started with a different privilege level, the Robot Service can communicate only with the one on the same privilege level (Assistant).
- If Assistant was started normally, then closed, then started as Administrator, communication will be broken because the Robot Service was initially started with normal privileges.
Since the Robot Service has a different permission level than the Assistant, or Studio, they are not able to communicate and the errors presented above are seen.
Note:
The behavior described is applicable to both User Mode and Service Mode Robots.
Solution
To avoid this, make sure that Assistant, or Studio is always started with the same privilege level as the Robot Service.
Updated 2 years ago